phpMyAdmin 5.0.0版于那时正式宣布正式发布。该版同4.9.3版与此同时存有,但是非官方所推荐没加装旧版PHP的采用者尽可能采用5.0.0版。此次5.0版预览中在囊括了4.9组成部份的大批改良以外,还导入了众多新机能。

admin5(admin5论坛)-第1张

项目组则表示也期望为那些运转旧版PHP的采用者尽可能保护phpMyAdmin 4组成部份,相关受全力支持的版和采用寿命中止年份的完备详细资料,参见https://www.phpmyadmin.net/downloads/上的受全力支持的版附注。phpMyAdmin 5.0.0版移除对旧版PHP版(5.5、5.6、7.0和HHVM)的全力支持,那些旧版早已无须获得PHP项目组的全力支持。

admin5(admin5论坛)-第2张

phpMyAdmin 5.0.0版对采用者界面展开了众多现代改良,在更为透明化的与此同时让标识符保护显得更为随心所欲。改良的部份机能主要包括:

● 预设情况下投入采用CSV求出的列中文名称

● 加进Metro主轴

● 建立手动递减列时手动加进检索

● 改良了求出快照

● 在没WHERE从句的UPDATE查阅以后,提示信息采用者展开证实

● 改良了向采用者表明严重错误的形式(主要包括容许更随心所欲地将严重错误文档导入到配置文件)

● 加进了个键以去除行(ctrl + l)并去除整座控制面板询问处(ctrl + u)

● 求出格式为MS Excel时采用字符集 Windows-1252

已知的问题

由于MySQL对身份验证方法的更改,7.4以后的PHP版无法向MySQL 8.0或更高版的服务器展开身份验证(我们的测试表明,问题实际上始于MySQL 8.0.11)。这与PHP严重错误https://bugs.php.net/bug.php?id=76243相关。

临时解决方法就是,将您的采用者帐户设置mysql_native_password为采用当前样式的密码哈希形式。不幸的是,这种缺乏协调的行为导致了所有PHP应用程序的不兼容性,受影响的不仅仅是phpMyAdmin。相关更多详细资料,您可以在https://github.com/phpmyadmin/phpmyadmin/issues/14220上查看我们的严重错误跟踪器项。

采用者可以通过https://phpmyadmin.net/downloads/下载。